Data Appearing Out of Sync

Incident Report for DeansList

Resolved

We can confirm that the changes made earlier have resolved this issue. We apologize for the disruption.
Posted Sep 15, 2025 - 21:32 UTC

Monitoring

At 10:30 AM EST we deployed a fix to route traffic away from the affected server. All features should resume functioning as expected and we are continuing to monitor all services.
Posted Sep 15, 2025 - 14:42 UTC

Identified

We've identified an issue in one of our database servers that's causing data to be delayed our out of sync. We are working replacing the affected server.
Posted Sep 15, 2025 - 14:01 UTC
This incident affected: DeansList for Educators (Core Services).